Delay for program c...
 
Notifications
Clear all

Delay for program change  

  RSS

Francois Berthiaume
(@mecnmuse)
Member Customer
Joined: 5 months ago
Posts: 7
05/28/2020 18:56  

Hi,

I putted some program change for my guitar,

but it's seem that there is a delay and it is not changing exactly where I want, and sometime I got the feeling that this is not the same delay when the song is playing.

Am I right or there is something that I am missing ?

Thank 

Frank


ReplyQuote
Staff
(@staff)
Admin Admin
Joined: 3 years ago
Posts: 82
05/29/2020 10:19  

@mecnmuse

a little premise: when you ask for a tech issue, it is better to write more informations as possible

for example we dont know what OS are you using, the Livetraker version, if you're using a trial or a pay version, what si hardware and midi interface you're using, the software used for connection and related drivers (type, kind, version) and also the settings are you putting in place

All that said, we can try to help you anyway

it's seem that there is a delay

often a delay is caused from the interface and/or the connection software

if you us a ASIO interface you can control latency to fine tuning it

it is not changing exactly where I want

it is not clear for us, but if you mean that you ask for a PC23 and receive a 48 , then it is something you have to check with your setting because livetraker doesn't change these values

hope this help a little 😉

This post was modified 2 months ago by Staff

ReplyQuote
Francois Berthiaume
(@mecnmuse)
Member Customer
Joined: 5 months ago
Posts: 7
05/29/2020 15:42  

@staff Hi, sorry for the missed information,

I use my pay version (LIVE TRAKER 4.5.0)

Windows 10 professional 1909

Steinberg Ur22MKII

ASIO DRIVER form Ur22MKII

Buffer Size : 256

We did the same test with the same configuration with another computer with a Babyface REM sound card and we had the same problem.

The problem is not about the value of the of the program change, this part is good when we ask for number 10 it is number 10. 

The problem is all about the timing: The program change are not steady. 

We tested our midi system with other software and it is on time. So there must be something that we do wrong.

François B.

 


ReplyQuote
jens luehmann
(@jens)
Member Admin
Joined: 3 years ago
Posts: 6
05/30/2020 06:18  

Hi François,

are we talking about milliseconds - delay?

please try to set your audio buffer to 1024 or 2048 samples to check out if it's getting better. In livetraker MIDI and AUDIO can't be in exactly in sync, i'm sure there is a delay of 1-5 ms each time. It's very difficult to coding it exactly. I did it the way it's written in the JUCE-Forum (juce audio library), but maybe there is a better solution now.

best regards

Jens


ReplyQuote
Francois Berthiaume
(@mecnmuse)
Member Customer
Joined: 5 months ago
Posts: 7
06/09/2020 04:59  

OK, Thank by setting it at 2048 it' is very better.

I got another question here.

If I want to insert let's say 4 guitar patch in the same song, do I have to create 4 tracks?

I am talking about the MIDI CTRL TRACK.

 

Thank 

François B.


ReplyQuote
Share:
English EN Deutsch DE Español ES Français FR Italiano IT